TimeLapse on downgraded 3G with 3.1.3

Locked
Chew
Posts: 2
Joined: Fri Jul 23, 2010 11:12 pm
Contact:

TimeLapse on downgraded 3G with 3.1.3

Post by Chew » Fri Jul 23, 2010 11:18 pm

iTunes says, that timeLapse does not work on 3.1.3 any more and asks me to upgrade to 4.0.1 before synchronization is possible, but after two days I downgraded from 4.0.1, because my 3G was soooo slow...
How do I get to run timeLapse again on my 3G with 3.1.3?

xyster
Site Admin
Posts: 605
Joined: Thu May 19, 2005 10:15 pm
Contact:

Re: TimeLapse on downgraded 3G with 3.1.3

Post by xyster » Sat Jul 24, 2010 7:35 am

That is not possible. TimeLapse will only run on iOS 4 or greater.

Chew
Posts: 2
Joined: Fri Jul 23, 2010 11:12 pm
Contact:

Re: TimeLapse on downgraded 3G with 3.1.3

Post by Chew » Mon Jul 26, 2010 8:02 pm

So what about the "old" TimeLapse Version? I paid money to use that one!!!

xyster
Site Admin
Posts: 605
Joined: Thu May 19, 2005 10:15 pm
Contact:

Re: TimeLapse on downgraded 3G with 3.1.3

Post by xyster » Mon Jul 26, 2010 8:30 pm

I don't have access to prior versions of TimeLapse. While I created TimeLapse, Apple has to approve apps so that they will run on your phone. In effect, Apple puts its stamp of approval on an app without which your iPhone will refuse to run the app. So I can't just provide you with an older version of the app as it won't have Apple's stamp of approval and so won't run on your phone.
If you have backups of the machine you sync your phone with it may be possible to find the old app in those backups.
While I understand your frustration I can't do anything to resolve the predicament you inadvertently put yourself in.

rgspro

Re: TimeLapse on downgraded 3G with 3.1.3

Post by rgspro » Sun Aug 01, 2010 11:19 pm

I had Timelapse installed and running on a 2g original iPhone running 3.1.3. The Timelapse version on my receipt shows 2.1. I had to restore my phone and I received an error message that Timelapse could not be installed on this iPhone. Timelapse worked before the update and restore and now it states that it needs 4.0 to run. I really do not think it is fair for the app to stop working because you only want it to run on 4.0

xyster
Site Admin
Posts: 605
Joined: Thu May 19, 2005 10:15 pm
Contact:

Re: TimeLapse on downgraded 3G with 3.1.3

Post by xyster » Mon Aug 02, 2010 7:26 am

I really do not think it is fair for the app to stop working because you only want it to run on 4.0


I really don't think it's fair for you to accuse me of trying to get you. I don't have a choice. Apple makes it impossible to maintain backward compatibility with older versions of their OS. When you install the latest iOS development kit it removes all the older ones so I cannot build older versions of the app anymore. This behavior is not documented anywhere so one only finds out after it's too late.

rgspro
Posts: 1
Joined: Sun Aug 01, 2010 11:22 pm
Contact:

Re: TimeLapse on downgraded 3G with 3.1.3

Post by rgspro » Tue Aug 03, 2010 8:57 am

I have many other apps which have updated after the release of 4.0. The other apps state "iOS 4.0 tested" and Requires iOS 3.0 and later. So, I think you did something wrong because if that was the case, every iPhone app update after 4.0 release, would have broken compatibility with anything lower than 4.0.

The bottom line, your app stopped working when you released an update, and the rest of the 175 apps on my phone still work after the developers updated their apps. As for the statement "This behavior is not documented anywhere so one only finds out after it's too late." You might want to check with Apple concerning backward compatibility, it exists.

Locked