Failed to Save Movie after missing a call

Failed to Save Movie after missing a call

Postby JR » Mon Feb 21, 2011 6:49 am

First - I LOVE this app! (Enough to let you know when I found something wrong)

Second - today I was recording a sequence and got a phone call which I never answered. However when I came back to my phone it was asleep. I woke it & first saw the alert for the missed call. Then the timelapse application (free version) complained that it could not save the movie as the data was in an unreadable format. So I lost everything it shot. :shock:

I am using an iPhone 4 32Gb. I was running one pic/5 sec, set to discard photos and use the dark display.

If I had set it to keep the photos - I assume that I wouldn't have this problem?

Alternately - I assume that Airplane Mode might also keep it from happening?

I can see where you might not be able to work around Apple's notification system and the way that forced it to fall asleep - but it would be far better to save the movie that was made so far rather than just dumping it.
JR
 

Re: Failed to Save Movie after missing a call

Postby xyster » Mon Feb 21, 2011 8:49 am

Hi JR,

Yes, phone calls will interrupt the session and currently the entire movie will be lost. Saving photos will keep all photos as they come in so you won't lose them. You are correct in stating that airplane mode will ensure the session doesn't end.

I'm currently working on some improvements to address unexpected interruptions such as phone calls. Depending on the exact circumstance it will allow TimeLapse to recover all or part of the movie generated until the interruption.

I hope to submit the improved app for Apple review in the very near future.

I appreciate your feedback and your patience while I get this resolved.
xyster
Site Admin
 
Posts: 605
Joined: Thu May 19, 2005 10:15 pm

Re: Failed to Save Movie after missing a call

Postby JR » Mon Feb 21, 2011 6:27 pm

Hey - what else could I possibly ask? You da man.
JR
 

Re: Failed to Save Movie after missing a call

Postby xyster » Tue Mar 01, 2011 7:34 pm

JR,

This issue is now addressed in TimeLapse 4.1.1. Thanks for your patience and don't hesitate to contact me again should you encounter anything else.
xyster
Site Admin
 
Posts: 605
Joined: Thu May 19, 2005 10:15 pm


Return to TimeLapse

Who is online

Users browsing this forum: No registered users and 6 guests