"interrupted" video

"interrupted" video

Postby Warshok » Thu Apr 28, 2011 11:08 pm

Hello, so last month I did a 6-hour, 6 second delay, played back at 15fps video with Timelapse. Worked great, just as I set it. Tonight I tried to do the same thing, but apparently it got "interrupted" half way through. I was plugged into external power the whole time. I had airplane mode on. I had even restarted the iPhone immediately before recording just in case that would make it more stable. I'm a bit frustrated that this event wasn't fully captured.

Do you have any suggestions to improve stability? The only thing I can think of would be to uninstall and reinstall the app in case the on-phone prefs were somehow corrupted.
Warshok
 

Re: "interrupted" video

Postby xyster » Fri Apr 29, 2011 9:18 am

I understand your frustration and I hope we can resolve this issue as quickly as possible. I'd like to ask you a few questions to get a better idea of what happened.
What did you see when you came back to the phone? Was it simply off?
Assuming the phone was off and you unlocked it, did it immediately bring you back to TimeLapse or was the phone in the home screen and you had to restart TimeLapse again?

How much free storage space do you have on your device? Is it possible it ran out during the session?

Which model iPhone is this and what were the exact settings so I can try to do the same and see if I can make it happen.
xyster
Site Admin
 
Posts: 605
Joined: Thu May 19, 2005 10:15 pm

Re: "interrupted" video

Postby Warshok » Mon May 02, 2011 1:36 pm

Thank so much for your quick response.

When I came back to the phone, it was "off", I unlocked it and it was at the home screen. I then opened Timelapse, which gave me a message that there was a recording that hadn't been saved and would I like to save it? I clicked yes or OK or whatever. When I went into the photo library, the video was only half as long as it should have been.

My settings:
Use rear camera.
snap photo every 6 seconds
start 30 seconds after tap
stop on 4/28/11 11:20pm
flash off
no preprocessing
discard photos
Video (large @ 15fps + Aud)
Completion sound (yes)
Dark Display (yes)

Weirdly, the "last session" info listed is a mix of info from the failed recording and one I did a few days earlier.

It's a Black 32gb iPhone 4 (AT&T). I had 12.8 gb free at the time of recording.

Again, thank you for responding and for making this app. When it's worked, it's been fantastic.
Warshok
 

Re: "interrupted" video

Postby xyster » Mon May 02, 2011 8:51 pm

Thank you for the information. I'll look into the problem.

From your description it sounds like the app crashed. Apple has a mechanism to report such app crashes back to the author but I'm currently not seeing any for TimeLapse.

I believe it works automatically when you sync your iPhone with iTunes. If you regularly sync your iPhone with iTunes, have you synced it since you encountered this problem? If not, can you sync it so it has a chance to report the potential crash?
xyster
Site Admin
 
Posts: 605
Joined: Thu May 19, 2005 10:15 pm

Re: "interrupted" video

Postby Warshok » Thu May 05, 2011 3:25 pm

Hi, yes I sync on a nearly daily basis. I can't explain why it wouldn't show the crash report. It happened on 4/28/11 sometime between 6pm and 9pm PDT.

Oh well, thanks for looking into it. I'll run another test one of these nights with the same settings and try to replicate it. I'll keep you posted.
Warshok
 

Re: "interrupted" video

Postby Warshok » Fri May 13, 2011 8:50 am

Greetings,

I've run a number of long tests since we spoke last with the same settings as seemed to have caused the crash, with no luck causing any instability.

The one difference is that I'm not using an MP3 audio file for the resulting video... considering that the failed video had a 1:53 audio track and that's about when the recording failed.... I'm guessing that might be the problem. It's weird because I recorded a much longer video several times before that with the same track and no problem, but hey if adding the audio in afterwards helps stability, I'm all for it!

Also, I have a small suggestion for the framing screen: it would be really helpful if that screen (and the subsequent "non-dark", mid recording screen) were to show the difference between portrait and landscape format. It's hard to tell otherwise if the recording is taking place with the correct orientation--there's no visual indication I can see.

Thanks again, and if I ever have any luck re-creating that crash, I'll fill you in!
Warshok
 

Re: "interrupted" video

Postby xyster » Fri May 13, 2011 9:25 am

Hello,

I was unable to reproduce the crash as well. I also tried various "shorter" audio clips to see if that was the source of the problem without results. I very much appreciate your patience and experimental attitude to the issue.

I will definitely add the orientation indicator to my feature list. Thanks for the idea.

Here's hoping it doesn't do anything like that again :)
xyster
Site Admin
 
Posts: 605
Joined: Thu May 19, 2005 10:15 pm


Return to TimeLapse

Who is online

Users browsing this forum: No registered users and 2 guests